Updating

Jul 22, 2010 at 3:07 PM

ME just went to 1.9.5.5 so I click on Check for update and jut this

LOG
------------------------------------------------------------------------------------------------------------------------------------

ErrorID: 1cccb7ee-449a-4c31-85ed-b463d1152dac
Date: 7/22/2010 8:05:30 AM
Message: Access to the path 'Updates' is denied.
Type: System.UnauthorizedAccessException
OS: Microsoft Windows NT 5.2.3790 Service Pack 2
Framework version: .NET CLR 2.0.50727;.NET CLR 3.0.4506.2152;.NET CLR 3.5.30729;.NET4.0C;.NET4.0E
Data:
Native Code:
StackTrace:    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.Directory.InternalCreateDirectory(String fullPath, String path, DirectorySecurity dirSecurity)
   at System.IO.Directory.CreateDirectory(String path, DirectorySecurity directorySecurity)
   at MouseExtender.Logic.Managers.UpdateManager.DownloadLatestRelease()
   at MouseExtender.Logic.Managers.UpdateManager.OnUpdatesDownload(Object sender, DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

 

Jul 22, 2010 at 3:16 PM

ok i shutdown ME and restated it and it worked

Coordinator
Jul 22, 2010 at 4:14 PM
Edited Jul 22, 2010 at 4:33 PM

We will check this issue.

Possible ME tried to create directory somewhere at denied location. After restart CurrentDirectory for application has changed and it continue working.

I have create WI:

http://me.codeplex.com/workitem/9027

 

Thanks for feedback!

Coordinator
Aug 3, 2010 at 9:55 AM

 

At new release 1.9.6.0 should not receive such an error any more.

Thank you for all yor help and feedback!