(Auto)update problem

Aug 26, 2010 at 12:59 AM

Hi,

I have version 1.9.6.0 currently, and I wanted to update the programme to 1.9.7.0.

When I click on "Check for updates", the button "Install updates" shows up after a couple of seconds, and a new "Updates" directory is created within my ME directory (also the new version zip file is downloaded into it).

However, when I click on the "Install updates" button, noting visible happens to ME, but the "Updates" directory with its content is deleted, and the programme is not updated at all, just the ME panel appears.

I tried to switch off my antivirus-firewall-spywarekiller, but it did not help anything.

Any ideas what to do?

Thx

Coordinator
Aug 26, 2010 at 8:15 AM
thms wrote:However, when I click on the "Install updates" button, noting visible happens to ME, but the "Updates" directory with its content is deleted, and the programme is not updated at all, just the ME panel appears.

When ME appeared again what version does it have? Please, check about page and let us know.

Aug 26, 2010 at 8:02 PM

It is still 1.9.6.0, so no change in version.

And it seems it did not even close and reopen the programme, just the panel containing my icons show up.

Coordinator
Aug 27, 2010 at 10:13 AM

It seems to be an issue in update system.

Please, send us your config file and we try to look into it.

Also try to update again (use context menu and click 'Check for updates') and let us know if it help you.

Thanks,

Alexey.

Aug 27, 2010 at 10:45 AM

 

Please, find it at:

http://thms.fw.hu/mouseextender/MouseExtender.cfg

http://thms.fw.hu/mouseextender/MouseExtender.HookLib.dll

Coordinator
Sep 2, 2010 at 11:50 PM

Thank you for the files.

I check your config and was able to udpate my ME.

I'm also check our database for error reports from your application. There are nothing related to updates.

Recently new version has been released. Please, try update now and if it doesn't help let us know.

Thanks,

Alexey.

Sep 4, 2010 at 9:07 PM

I now manually updated my ME.

If a new version is launched, and I cannot update normally, I'll show up again.

Anyway, thanks for your help up to now.

Thomas

Coordinator
Sep 7, 2010 at 4:29 PM

Hi

Maybe problem is with permissions?

Are you launching ME as an Administrator?

 

Sep 7, 2010 at 9:14 PM
AlexSorokoletov wrote:

Hi

Maybe problem is with permissions?

Are you launching ME as an Administrator?

 

 

Yes, I log in as an admin.

I have also set the permissions of both the folder of ME and all the files therein to have all access to them. However, I still had the problem at the time of my last post (then, I updated manually by replacing the old .exe file with the new one).

Now, I would like to see at the next update whether it manages to update automatically.

At my last manual update, I just replaced the .exe file, but the .cfg and .dll not. Do you think this can be a problem? These .cfg and .dll files are from 3-4 versions before.

Coordinator
Sep 8, 2010 at 10:20 AM

thms,

Replacing just exe file could cause several issues. You should better extract zip archive content to your current application folder.

Regarding Admininstrator rights Alex mean that you should launch application "as adminsitrator" (right click on exe file). Please, check with the new release when available.

 

Thanks,

Alexey

Sep 11, 2010 at 11:33 AM

Alexey,

In case if I extract and use just the "new" .cfg and .dll files, then all my settings (programmes and websites to launch would be lost, as their source is included in the "old" files.

Any idea how to save them into the new files without adding them manually one-by-one?

Thx,

Thms

Coordinator
Oct 6, 2010 at 1:25 PM

Thms,

If you extract to existent ME folder you won't lost your items as old cfg files will be loaded at new version.

Thanks,

Alexey.

Oct 19, 2010 at 10:08 PM
strashok wrote:

Thms,

If you extract to existent ME folder you won't lost your items as old cfg files will be loaded at new version.

Thanks,

Alexey.

 

Alexey,

I manually update (download the file from the website, extract it and reopen ME), that is the only I could update.

Maybe for the next version, automatic update will work.

I will let you know what is the result.

Thanks,

Thomas

Nov 3, 2010 at 10:10 PM

Hi Alexey,

Still just manual update works even with admin rights.

I tried automatic with version 1.9.9.1 and 1.9.9.2, but useless.

No worries, I'll do the manual update everytime, it is a great program anyway! :)

Bye,

Thomas