Problem With SolidWorks 2010

Oct 7, 2010 at 8:08 PM

I use SolidWorks 2010 and if you USe ME to Run it i get an dialog with an progressbar in Solidworks Preparing SolidWorks for first use. This may take seveal minutes  then it lock up (Not Responding)

when i open Solidwork through explorer or the startmenu it open with out the dialog an function fine

I'm going to pause to code to see if there is something i can find out.

 

Oct 7, 2010 at 8:14 PM

ok I got it to work

I removed Working Directory and now it works fine
I also can't get it to happen agian

Coordinator
Oct 8, 2010 at 11:54 AM

This is very strange behavior.

Jacob, could you please try to reproduce this by creating ME item again with Working directory.

Update us upon you get the result.

Thanks!

Oct 8, 2010 at 3:17 PM

I can't get it to reproduce
i even delete the MouseExtender.cfg
and try run as a diffrent user

I wish i would have go in the code to test it
i'm going to try a system restore to see if that will do something



Oct 8, 2010 at 4:13 PM

ok it is back
I did a system restore and it looked like it was ok but then I added SolidWorkd with the Add running program and it came back

 

I did Some Debuging and found this
then change startInfo
I pass my Domain,username,and password into startInfo.UseShellExecute that fixed it
but I don't know why, it beeing ran be the same user

 


i try to remove the Working directory agin that did not fix it

Coordinator
Oct 15, 2010 at 8:29 AM

Well, that's very strange.

What OS do you have? I'm asking because we can create a script (.cmd for XP, or .ps1 for Vista or higher) that will start SolidWorks with appropriate data (usernames, domains, working directories). And then add this script as an item to ME (with icon of SolidWorks).

That's just a workaround/

Alex.

Oct 15, 2010 at 3:16 PM

the problem is go again I don't know what cause it
if the problem comes back i will let you know

I have Windows 7 Professional x64